La domotique à 2€, arduino non détecté par l’ordinateur

Il arrive que l’ordinateur ne détecte pas certains arduinos lorsqu’on les branches. Il s’agit d’un driver manquant, celui ci doit être installé manuellement, voici comment faire, et ci dessous, les liens :

Lien du fabricant officiel 

Faire un don permet de maintenir cette chaine en vie et permet également d’effectuer des recherches  indépendantes dans le bâtiment et l’énergie. En effet, tout est réinvestis pour produire de nouvelles vidéos (achat de matériaux et de produits) pour faire de nouvelles recherches, des essais, et test que je vous présente. Même un petit montant apporte sa pierre à l’édifice et sans cela, cette chaine serait vouée à mourir. Donc un grand merci pour votre soutien et pour vos dons. Je ne peux que vous encourager à continuer en cliquant sur les liens ci-dessous :

Soutenir par tipeee 

Soutenir par carte ou paypal

Soutenir par patreon

Soutenir par utip

Acheter mon livre

Acheter une séance de coaching privé

Transcription texte la domotique à 2€, arduino non détecté par l’ordinateur driver ch340g :

Salut, aujourd’hui dans cette vidéo sur la domotique à 2€, je vais aborder un point bloquant que j’ai rencontré, le fait d’acheter des composants qui sont pas chères, le moins chère possible. Là, face à moi, j’ai tous les arduinos que j’ai achetés. Au tout début, j’ai acheté ces deux premiers arduinos, un arduino UNO et un arduino MEGA. Pas de souci, cela a fonctionné. Puis j’ai passé une autre commande où j’ai acheté une douzaine d’arduinos, sauf que j’ai pris des arduinos premier prix, ils coutaient environ 2€30 pièce. Donc j’ai des arduinos qui sont des copies chinoises d’arduinos originaux chinois aussi. Mais lorsque j’ai branché ces arduinos sur mon ordinateur, cela n’a pas marché. Et je veux attirer votre attention là-dessus, parce que lorsqu’on va chercher à tirer les prix sur certains composants comme cela, on peut se retrouver face à certaines galères comme celle-ci. Et en fait ce qui m’a mis la puce à l’oreille, c’est qu’entre un arduino original, et une copie, la puce n’a pas la même forme, c’est le même modèle, mais le boitier de celle-ci est différent. Je me suis dis que c’était peut être à cause de cela, mais je ne savais pas trop, j’ai passé une dizaine d’heures à galérer, chercher des solution, essayer des choses sans être sur. désinstaller le logiciel, réinstaller le logiciel arduino, chercher des nouveaux drivers et ne pas trouver. Enfin bref, une grosse galère. Et le problème ne venait pas de l’ ATM238P, mais la puce qui permet la communication entre l’ATM328P et l’ordinateur. Sur les copies, il s’agit d’un CH340G, alors que sur les originaux, il s’agit ATmega8. Sur les originaux, on peut lire qu’il s’agit d’un ATLEM ATmega8. Et sur les copies, il s’agit d’un CH340G. Donc il était assez problématique d’avoir ces arduinos qui ne marchaient pas et chercher des solutions sur des forums, tenter des choses qui ne marchaient pas, ouvrir des pages internet sans savoir si il s’agissait des bonnes pages ou s’il s’agissait de virus. Télécharger des programmes avec ensuite des messages de mon ordinateur disant êtes vous sur du programme que vous installez, nous n’avons pas de vérification… Enfin bref, on se demande si on fait les bonnes choses ou s’il s’agit de virus. Et donc, j’ai tout de même après environ 10 heures réussi à trouver une solution. La solution, regardons la ensemble. En cherchant sur des forums, j’ai trouvé un site russe, donc il faut se mettre à l’alphabet cyrillique, donc on peut lire qu’il est écrit module CH340G, et donc ce module ch340g, c’est ce qui permet la communication entre notre arduino et l’ordinateur. Il faut sortir un peu des sentiers battus et aller chercher des choses sur des sites où nous n’irions pas habituellement, et donc voila ce que j’ai trouvé, sur le site russe, il est écrit nouveaux drivers année 2017, version 3.4 USB, CH340 et CH341, c’est celui là que j’ai téléchargé, ensuite dans mon ordinateur, périphériques et imprimante, lorsque je branchais mon arduino, j’avais le sons de l’ordinateur qui indiquait que je connectais un périphérique USB branché. Mais il y avait un point d’exclamation. Donc la solution, dans les propriétés du périphérique USB, il était écrit qu’il y avait un problème, modifier les paramètres, pilotes, mettre à jour le pilote. Ensuite, recherche automatique du pilote, rien n’était détecté. Il fallait sélectionner rechercher un pilote sur mon ordinateur. Puis, sélectionner le fameux ch340g téléchargé sur le site russe. Il fallait donc indiquer le chemin d’accès pour qu’il puisse mettre à jour le pilote. Puis en cliquant sur suivant, il a mis à jour ce pilote, et à partir de ce moment là, mes arduinos ont fonctionnés. Voila, il s’agit de la solution, si jamais vous rencontrez ce même problème. Mais concrètement, dés fois on peut avoir le choix entre des arduinos à 6€, et dés fois on peut avoir des arduinos à 2€. La différence, elle est là. Et, il s’agit tout de même d’une dizaine d’heures passées pour résoudre ce problème. Je voulais vous avertir par rapport à cela, car derrière, il y a tout le budget que l’on va dépenser pour nos projets de domotique à 2€. Il faut donc faire un choix entre domotique à 2€ et domotique à 10 €, au choix, en tout cas, j’espère que cette petite vidéo pourra vous aider pour vos projets, je vous souhaite bon courage et je vous dis à plus tard, salut.

Partager l'article
  •  
  •  
  •  

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.